Comunicación Profibus DP entre S7-300

febrero 24, 2010

A falta aún de sacarle jugo a la Cp 343-1 Advanced con el diseño de aplicaciones web integradas de control mediante el uso del HTML Code Generator de Siemens, nos metemos en uno de los sistemas más ampliamente usados en el ámbito de las comunicaciones industriales, que aunque poco a poco va siendo desplazado por sistemas más versátiles como Profinet, todavía tiene mucha vida por delante gracias a la gran cantidad de nodos profibus actualmente instalados.

Para comenzar por el principio, que suele ser lo más conveniente, os dejo un pequeño videotutorial de cómo realizar la configuración de la comunicación Profibus entre dos S7-300 mediante STEP7. El objetivo es intercambiar dos áreas de memoria entre dos S7-300 funcionando como Maestro/Esclavo. Pretendemos pues reflejar el byte de entrada EB124 de uno de los equipos (maestro) en el byte de salida AB124 del otro equipo (esclavo) y viceversa.

Es especialmente interesante la estructura de los dos bloques de programa OB1 que cargamos en cada uno de los autómatas. No olvidéis que a pesar de que las transferencias configuradas vía STEP7 son tan sencillas como AB0->EB0 en un equipo y AB0->EB0 en el otro, tenemos que mover a esos datos de salida (AB0) y de entrada (EB0) los respectivos valores EB124 y AB124 que queremos que se reflejen en cada uno de los equipos.

El siguiente paso es incluir a los S7-200 en las comunicaciones Profibus. Poco a poco se anda el camino. Espero que os resulte de utilidad.

Anuncios

4 comentarios to “Comunicación Profibus DP entre S7-300”

  1. oscar bocanegra Says:

    este material es muy bueno y por lo cual , les felicito pu haber subido al internet y ojala continuen con esta actividad.
    excelente!!!!

  2. DANILO Says:

    hola que tal me parece muy interesante todo el tema pero no se podria explicarme como hago para ponerme en online desde una pg siemens con un cable profibus aun st 300 te lo agradescon mucho gracias saludos

  3. Joaquin Says:

    Buenas, en primer lugar quería felicitarle por la grandiosa idea de esta página y sus contenidos.
    Ahora quisiera plantearle una cuestión acerca de este vídeo.

    He realizado este videotutorial siguiendo tal cual el proceso que usted realiza. Cuando cargo las configuraciones en los autómatas se me encienden los leds BF y SF (Como usted menciona en el vídeo) pero al conectarle el cable profibus el led SF del autómata esclávo se me queda en rojo fijo, mientras que todos los demás están apagados. ¿A qué puede deberse?

  4. Joaquin Says:

    Buenas, en primer lugar quería felicitarle por la grandiosa idea de esta página y sus contenidos.
    Ahora quisiera plantearle una cuestión acerca de este vídeo.

    He realizado este videotutorial siguiendo tal cual el proceso que usted realiza. Cuando cargo las configuraciones en los autómatas se me encienden los leds BF y SF (Como usted menciona en el vídeo) pero al conectarle el cable profibus el led SF del autómata esclávo se me queda en rojo fijo, mientras que todos los demás están apagados. ¿A qué puede deberse?

    Gracias y un saludo.


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: